Since I came to notice that there’s considerable amount of traffic coming to this site seeking for Windows Vista Drivers for ZTE ZXDSL 852 modem, I thought of uploading the Vista driver I have with me for that modem and make it available for download through this site. You can find the Vista Driver for ZTE ZXDSL 852 modem here. I got this driver from Sri Lanka Telecom, who is my Internet Service Provider but they recommend ZTE ZXDSL 852 modem to be best use with Windows XP rather than Windows Vista. But this driver works well for me and I hope it will help you too to sort out your problems with ZTE ZXDSL 852. Drivers for Vista 64 bit and XP 32 bit Operating Systems are also included in the download pack.

Bookmark and Share


This entry was posted on 1:51 AM and is filed under , , , , , , , , , , , , . You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

28 comments:

    Dame de pique said...

    thank you for the driver.

  1. ... on November 15, 2008 at 3:46 AM  
  2. SanJ Wijeratne said...

    The original driver installation will set VCI, VPI and Encapsulation Formats in to the values specified by Sri Lanka Telecom. Please go to Device Manager > WAN/ATM/ADSL mini port > Properties > Select PPP Tab to change VCI, VPI and Encapsulation Formats as specified by your service provider. If you need any help, please refer this manual.

  3. ... on November 16, 2008 at 4:23 AM  
  4. LeDoyen said...

    thank you very much

    read this: http://www.forumdialna.com/index.php/topic,383.0.html

  5. ... on January 4, 2009 at 8:51 AM  
  6. C4 said...

    thank you very much

  7. ... on May 23, 2009 at 7:54 PM  
  8. bandara said...

    Thank you
    Its realy help me to keep my old modem wwithout buying new one.
    Thanks

  9. ... on August 6, 2009 at 3:00 AM  
  10. Praveenie said...

    thanks for the driver.... :)

  11. ... on September 2, 2009 at 11:54 PM  
  12. Alibouafia said...

    I urgently need Downloading Drivers for ZTE ZXDSL 852 Modem - 32 Bit and 64 Bit, but I couldn't do it from your blog. Could you help me please !

  13. ... on December 20, 2009 at 12:46 PM  
  14. SanJ Wijeratne said...

    @ Alibouafia,

    Yes Certainly , You may post what ever you want to ask from me, here. I'll do my best to help you.

  15. ... on December 20, 2009 at 8:02 PM  
  16. Alibouafia said...

    Could you provide me with ASAP a link to Download Drivers for ZTE ZXDSL 852 Modem - 32 Bit and 64 Bit.

  17. ... on December 21, 2009 at 12:59 AM  
  18. SanJ Wijeratne said...

    @ Alibouafia,

    Its already given in my blog post. You may carefully read it again :)

  19. ... on December 21, 2009 at 1:02 AM  
  20. Alibouafia said...

    I couldn't download via the link in the upper side of the blog page. How to proceed ? Thanks in advance.

  21. ... on December 21, 2009 at 1:08 AM  
  22. Dilhani said...

    Helo Mr. SanJ Wijeratne...


    Can you give me the ZTE ZXDSL 852 software driver for windows 7 professional?
    Or Is there anyway to upgrade the vista driver to the windows 7? I have ZTE ZXDSL 852 software driverfor win xp/win 2000/ windows vista. I am really tired in seeking the driver
    throughout the internet.Please help me soon.I installed windows 7 in my laptop.But I can't connect
    to the internet.I also asked about this issue from slt net via calling to 1243.But they don't have the ZTE ZXDSL 852 software driver for windows 7 professional and they asked me to buy a router.
    If you find the driver and if you can please be kind enough to send it to dilhaniranaweera@yahoo.com.

  23. ... on December 22, 2009 at 8:03 AM  
  24. SanJ Wijeratne said...

    This driver might work on Windows 7. I couldn't test it though, so just have a go at it and tell me if can :)

  25. ... on December 22, 2009 at 7:17 PM  
  26. Dilhani said...

    Mr. Sanjaya Wijeratne,

    Thanks for your help!!I installed the driver you gave.I think the driver was successfully installed.I also got the shortcut
    icon on the desktop.but when I dial by double clicking on that icon it gives an error "Error
    628:The connection was terminated by the remote computer before it could be completed."I think that some settings should
    be correct.Can you tell me the settings in the dial up property window(the window we get after click on the "properties"
    button in the dial up window)and WAN/ATM/ADSL miniport properties window.(Device manager->network adopters->WAN/ATM/ADSL miniport)

    If you can please give a try to install this driver in windows 7 and test it.Please this will be a big support for me....

  27. ... on December 24, 2009 at 3:57 AM  
  28. Ishani said...

    Hello,
    Do you think I can use this driver for Windows 7 as well.
    Thanks,
    Ishani-

  29. ... on January 4, 2010 at 6:19 PM  
  30. SanJ Wijeratne said...

    @Ishani

    You may try this driver for Windows 7.

  31. ... on January 4, 2010 at 7:41 PM  
  32. Melissa said...

    Hi SanJ! It still isn't working for me. I get the affirmative message that the installation is successful. I get the ADSL circular icon that shows the status. But I don't have the ZSDSL 852 icon for the log on. When I go to device manager, I don't have an option for WAN/ATM/ADSL miniport. I only have options for my laptop's ethernet connection and wifi. Do you have any suggestions for me?

  33. ... on January 9, 2010 at 1:38 AM  
  34. V LAkSHmAN NeLLAiNaYaGAM said...

    Hi

    Need your help Please....I get the ADSL circular icon that shows the status. But I don't have the ZxDSL 852 icon for the log on.

    Please help me...Very Urgent

  35. ... on March 11, 2010 at 5:01 AM  
  36. SanJ Wijeratne said...

    @ V LAkSHmAN NeLLAiNaYaGAM

    I think your problem is you don't see a link to connect to the Internet after installing ZTE driver. Just go to your network and sharing center, select your network connection and add a shortcut to your desktop.

  37. ... on March 11, 2010 at 5:08 AM  
  38. V LAkSHmAN NeLLAiNaYaGAM said...

    I dont see any network connections icon there also.
    The issue is I see the status icon but the connection icon is not available to connect to the internet.
    This is working fine with other machines. But its not working in my laptop only(Windows Vista 32-bit). Is there any configuration I have to change to see that connection icon while installing the driver.(Turned off Firewall) ....Please help

  39. ... on March 11, 2010 at 9:14 PM  
  40. SanJ Wijeratne said...

    @ V LAkSHmAN NeLLAiNaYaGAM
    If there's no network being setup, probably there might be an error with your installation. Please try to re-install or you can manually create a connection using network manager .

  41. ... on March 11, 2010 at 9:19 PM  
  42. V LAkSHmAN NeLLAiNaYaGAM said...

    Thanks for your reply. It dint work actually. Anyway I will try that again.
    Thankyou very much for your help.

  43. ... on March 11, 2010 at 9:53 PM  
  44. H.W Thushara Indika said...

    The link you provided on January 4, 2010 comment isn't working. Could you share those files in some other place. Actually SLT is responsible for providing Windows 7 compatible driver for ZTE ZXDSL 852 as it is their primary product given to all ADSL subscribers.

  45. ... on March 12, 2010 at 9:15 PM  
  46. SanJ Wijeratne said...

    @ H.W Thushara Indika
    Thank you very much for reporting me about the broken link. Please Find the Windows 7 Driver HERE

  47. ... on March 12, 2010 at 9:25 PM  
  48. Udesh Fernando said...

    Dear Sanj

    I cant find the driver for ZTE modem for Vista 32bit.

    though i hv the slt vista pack too with me even i install it i cannot run internet mchgn. some times im connected to the net but in the network map it doenst show and the other thing is the browser says that SERVER NOT FOUND
    but the same modem operates in my Win XP pc, not in the laptop
    pls help

  49. ... on March 17, 2010 at 9:53 PM  
  50. H.W Thushara Indika said...

    Hey! I downloaded Zip file you gave and I could succesfullt install my modem to Windows 7. But Still I face the problem, because I can't access the Internet using installed modem. It gives an error when I'm going to connect by clicking the connection short cut saying "Error 619: Server do not open the connection etc...".

    I found that SLT need VPI and CCI configuration set to 8 and 35 respectively, and I could set them as in their manual, but ZTE control panel's setup tab shows installed profile as "PPPoA(VPI=0,VCI=35)". I think this is a clue but I still can't find a solution. If you have a solution, please post it!

    H.W Thushara Indika

  51. ... on September 25, 2010 at 9:47 AM  
  52. Deepal said...

    please send the Drivers for ZTE ZXDSL 852 Modem - windows 7 (32 Bit)

    Thanks,

    Deepal

  53. ... on March 12, 2012 at 12:08 AM  
  54. Puvaneswaran Vathsalyan said...

    Sanjay, I couldn't find the Download Link. Can you upload it again?

  55. ... on July 21, 2012 at 8:58 PM